?

Log in

No account? Create an account

Previous Entry | Next Entry

Well, That's ... Geeky

There are three hard drives sitting in what will be the "office" (possibly darkroom) of the Studio which are problematical; some less so than the others.

All of them came out of used PC's that we acquired for Ruthie. She's over that, as I mentioned back in October she purchased herself a new PC. Or maybe it was September, doesn't matter.

The rather not so problematical drive is the one which ScanDisk, doing a surface scan to lock out bad clusters, delivers the message "... encountered a data error while reading root directory entry number 0." Right, then, as Bones would say to Kirk, "It's dead, Jim." Possibly I will be able to access it as a slave and salvage data.

The one I replaced it with, now, it delivers this message while booting: Stop: "0x00000024 (0x0019025E, 0x0EF033744, 0x0EF03339C, 0xBFF58D3C) NTFS_FILE_SYSTEM" and there's more about disabling anti-virus software (just how does one do this when one can't get the OS to run?) and such to get at the drive. It just hangs there.

While I am a geek, or a nerd, I'm not so much a tech. This one, also, I wonder will I be able to bypass the boot problem and recover data?

Then there's the one which came out of the Gateway Gift PC (the previous two were drives I purchased new). It is loaded with Win XP, and while booting hangs up with this message: NTLDR is missing

I guess I need to find out what the NTLDR is.

ETA (11/28/2005): yup, confirmed wht NTLDR is, it's what I suspected, and it looks less hopeful for that drive as anything other than a slave for data recover. Life is not boring.

Tags:

Comments

ihgreenman
Nov. 27th, 2005 07:49 pm (UTC)
Here's what I'd say:

First off, don't even bother trying to boot off of the disk. Put it as a slave on another system. You might be able to read the data you want off of the disk that way.

There are some other tricks you can try, but first, here are a few relevant questions:

Just how large is the disk? How quickly did it fail? How much space can you free up temporarily on another system? How important is the data on the disk?
madshutterbug
Nov. 28th, 2005 05:14 am (UTC)
Taking Things Backwards
The data on the disk is quite important to Ruthie. I do need to recover it, if possible.

Can free up quite a bit of space, particularly if I can get the (older) system to recognize the ATA drive/controller which I purchased to replace this.

Both drives worked for about a month to three months. One of them I know is or was under a recall from the manufacturer, as we also had several of them in PC's in the OR where I work. Both drives which are now out of sorts are 40 Gb drives, both from Maxtor.

The drive which came out of the Gateway and has the NTLDR error is a Quantum, has Win XP loaded, and is of a somewhat unknown history, which is it was a gift from a friend, who left it stored at our place for nearly a year after moving back to the area following a failed relationship. It had been a gift to her from her ex, and I don't know how far back. She's not technical at all; no original disks or manuals with the box and no info from her.

I also don't know what the original OS is, but suspect the XP installation is the original. I'm not even sure of the size of the drive; I think it's a 60 Gb drive. Also, when I installed the ATA drive/controller mentioned above, on a boot the BIOS would find the controller card, and the drive, but would not find any other drives; there's a DVD, a CD-RW, and a 3.5 floppy all on that machine, and all the drives connected to IDE controller on the motherboard. I am thinking that something happend to the controller, since none of the drives are being found.

Did my Google homework this morning, so I've got a couple pointers for what to do with that specific drive. The two Maxtor drives I'd figured on trying to access as slaves.

Sideline note: if I can find an IDE controller card, could I install it in that Gateway and bypass the controller on the motherboard?
Thanks!
ihgreenman
Nov. 28th, 2005 08:32 am (UTC)
Re: Sideline
Most motherboards can have the onboard IDE controller(s) replaced. (Or if it is an EIDE controller, you can have a grand total of four active controllers.)

However, be careful: If you decide you will need to replace the motherboard on a Gateway, make sure that you replace the power supply as well. The wiring on the power pins to the motherboard is not standard, and *will* fry any motherboards that you try and put in. This was a deliberate attempt at customer lock-in.
ihgreenman
Nov. 28th, 2005 08:54 am (UTC)
Re: Taking Things Backwards
You can try mounting the drive as a secondary drive, and see if you can just copy files from there. If you can do that, that's the easiest way to handle it.

If that doesn't work, I'd next try making a complete _image_ of the drive (at least the copyable bits), and then recovering data from there. There are a number of utilities that can do this, including Ghost,
RTT tools (which I have no direct experience with yet, but I think I will be ordering a copy and playing around with it sometime soon), I know that there are some freeware utilities to do this -- including the "dd" command which is available under Cygwin (for Windows) as well as under Linux.

The advantage to doing it this way is that you are no longer working with a drive that is failing underneath you. The disadvantage is that you may need to try this a couple of times, because some data might not be readable one time, and readable the next.

There are a few destructive techniques, which I'll mention later. (After you've tried the non-destructive techniques.)
ihgreenman
Nov. 28th, 2005 08:57 am (UTC)
Re: Taking Things Backwards
A thought occurs to me: have you tried reading these drives in a completely different machine? If the IDE controller is hosed, it can look like a drive failure.

Also, you might want to try playing around with the orientation of the drives. I know some older drives that can only be read when the platter is spinning vertically, not horizontally.
madshutterbug
Nov. 28th, 2005 09:38 am (UTC)
Re: Taking Things Backwards
Yes, to the one from the Gateway (hosed IDE controller). Tried it in a different machine, and it yielded the NTLDR message. Wouldn't even get that far in the Gateway.

I only see two connections for the IDE cables; this brings me to presume it's IDE vs EIDE.

The two Maxtor drives failed in the one PC that's still got a functional IDE controller (the "different machine" referenced above).

Latest Month

August 2019
S M T W T F S
    123
45678910
11121314151617
18192021222324
25262728293031

Tags

Page Summary

Powered by LiveJournal.com
Designed by Tiffany Chow